TokenIntrospectionResponse
Constructors
Properties
REQUIRED. Boolean indicator of whether or not the presented token is currently active. The specifics of a token's "active" state will vary depending on the implementation of the authorization server and the information it keeps about its tokens, but a "true" value return for the "active" property will generally indicate that a given token has been issued by this authorization server, has not been revoked by the resource owner, and is within its given time window of validity (e.g., after its issuance time and before its expiration time).
OPTIONAL. Confirmation of the key the token is bound to (RFC 7800 3.1), for a DPoP-bound token the JWK SHA-256 thumbprint of the DPoP key in jkt (RFC 9449 6.2). A resource server MUST check that the DPoP proof of the request is signed with that key (RFC 9449 7.1).
OPTIONAL.Integer timestamp, measured in the number of seconds since January 1 1970 UTC, indicating when this token will expire, as defined in JWT RFC7519.